私はクラスポイントを持っています:
public class Point
{
private double _x;
private double _y;
}
また、私はgetX()
、getY()
メソッドを持っています。2つのメソッドを定義する必要があります:
1. public boolean isAbove(Point other)
2. public boolean isUnder(Point other)
だからこれは私が思いついたものです:
public boolean isAbove(Point other)
{
if (this._y <= other._y)
{
return false;
}
else
{
return true;
}
}
public boolean isUnder(Point other)
{
}
私はいくつかのことを試してみましたがisUnder
、異なる結果が得られました。これらの2つのメソッドを書く正しい方法は何ですか?
** 重要 **
私はisAbove()
メソッドを使用する必要がありますisUnder()
!!