データベースと相互作用するクラスの標準的な命名規則(CRUDのものまたは重複のチェック)などはありますか?今、私はそれをHelperと名付けました。たとえば、「Subscriptions」という名前です。そのテーブルと対話するクラスは「SubscriptionHelper」という名前になります。
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace LoopinWineBackOffice.Helper
{
public class SubscriberHelper
{
public static bool IsEmailAlreadyInUsed(string email)
{
using (var dc = new LoopinWiineContainer())
{
return dc.Subscribers.Any(item => item.Email==email.Trim());
}
}
}
}
私のサンプルコードはこのようなものです。